<!DOCTYPE html>
<html lang="en-US">
<head>
<![endif]-->
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">
<title>City plans, Polly Reed improvements, public safety highlights of Center Point City Council meeting  &#8211;  The Trussville Tribune</title>
<meta charset="UTF-8" />
	<link rel="stylesheet" type="text/css" href="http://www.trussvilletribune.com/wp-content/themes/goodnews/style.css" />

<link href='http://fonts.googleapis.com/css?family=Play:400,700' rel='stylesheet' type='text/css'> 
<!-- Custom favicon -->
<link rel="shortcut icon" href="http://www.trussvilletribune.com/wp-content/uploads/2014/12/favicon.ico" />

<!-- feeds, pingback -->
  <link rel="alternate" type="application/rss+xml" title="The Trussville Tribune RSS Feed" href="http://www.trussvilletribune.com/feed/" />
  <link rel="pingback" href="http://www.trussvilletribune.com/xmlrpc.php" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.trussvilletribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp_dlmp_styles-css'  href='http://www.trussvilletribune.com/wp-content/plugins/download-monitor/page-addon/styles.css?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.cycle.all.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.tools.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.color.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.jplayer.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/effects.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.tweet.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.prettyPhoto.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.tipsy.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.fitvids.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/jquery.li-scroller.1.0.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://www.trussvilletribune.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.trussvilletribune.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.trussvilletribune.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Pinson woman wanted for FTA on possession charges' href='http://www.trussvilletribune.com/2017/03/09/pinson-woman-wanted-for-fta-on-possession-charges/' />
<meta name="generator" content="WordPress 4.7.3" />
<link rel="canonical" href="http://www.trussvilletribune.com/2017/03/10/city-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting/" />
<link rel='shortlink' href='http://www.trussvilletribune.com/?p=38962' />
<link rel="alternate" type="application/json+oembed" href="http://www.trussvilletribune.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.trussvilletribune.com%2F2017%2F03%2F10%2Fcity-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.trussvilletribune.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.trussvilletribune.com%2F2017%2F03%2F10%2Fcity-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting%2F&#038;format=xml" />
	<style type='text/css'>
	.download-info .download-button {
		background-image: url(http://www.trussvilletribune.com/wp-content/plugins/download-monitor/page-addon/downloadbutton.gif);
	}
	.download-info .more-button {
		background-image: url(http://www.trussvilletribune.com/wp-content/plugins/download-monitor/page-addon/morebutton.gif);
	}
	</style>
<meta property="og:site_name" content="The Trussville Tribune" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="565982923603757" />
<meta property="og:url" content="http://www.trussvilletribune.com/2017/03/10/city-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting/" />
<meta property="og:title" content="City plans, Polly Reed improvements, public safety highlights of Center Point City Council meeting" />
<meta property="og:description" content="By Nathan Prewett For the Tribune CENTER POINT – The Center Point City Council met early on Thursday night to hear a presentation on the first draft of long term plans for upgrades and improvements to the city. The plans range from marketing the city to potential buyers of property to improvements for infrastructure such&hellip;" />
<meta property="og:image" content="http://www.trussvilletribune.com/wp-content/uploads/2016/09/IMG_3030.jpg" />
<meta property="og:image:width" content="3264" />
<meta property="og:image:height" content="2448" />
<meta property="article:published_time" content="2017-03-10T05:38:23+00:00" />
<meta property="article:modified_time" content="2017-03-10T05:38:23+00:00" />
<meta property="article:author" content="http://www.trussvilletribune.com/author/cyow/" />
<meta property="article:section" content="Local News" />
<meta property="article:tag" content="Online" />

    <!--[if lt IE 9]>
<script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE9.js"></script>
<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

      <script type="text/javascript" src="http://maps.google.com/maps/api/js?sensor=false"></script>
<!-- Place this render call where appropriate -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
        <style type="text/css">
body {
background-repeat:repeat;
background-attachment: scroll;
 
font-size:12px;
font-weight: normal;
}

.single_article_content h1 {
font-size:36px;
font-weight: normal;
}

.single_article_content h2 {
font-size:30px;
font-weight: normal;
}

.single_article_content h3 {
font-size:24px;
font-weight: normal;
}

.single_article_content h4 {
font-size:18px;
font-weight: normal;
}

.single_article_content h5 {
font-size:14px;
font-weight: normal;
}

.single_article_content h6 {
font-size:12px;
font-weight: normal;
}
/*#header .logo {
    margin-top:px;
}
*/
/*******************************************************************
 *      Colors Start Here 
 *****************************************************************/
/*    Topbar & bottombar     */
.top_bar, .top_bar ul.top_nav li ul, .bottom_bar {
background-repeat:no-repeat;
background-attachment: scroll;
 
}
/*  Header  */
#header {
background-repeat:repeat;
background-attachment: scroll;
 
}
/*      Navigation      */
#navigation .nav_wrap {
background-repeat:repeat;
background-attachment: scroll;
 
}
#navigation ul.nav li ul li a:hover {
color:;
background-repeat:repeat;
background-attachment: scroll;
 
}
/*     Feature      */
/*     Widgets  */
.sidebar .widget, .lates_video_news, .news_box, .cat_article, .ticker_widget {
}
.sidebar .widget .widget_title, .lates_video_news .widget_title {
}
/*  NewsBox */

/* News Ticker */
.ticker_widget {
}
ul#ticker01 li a {
font-size:13px;
font-family:play;
font-weight: normal;
}

/* News Ticker */



</style><meta name="google-site-verification" content="4pbNnUfnXhKK_nDTgDaia9TkU34Htaxy7D9Kk5NnVK4" />
<link href="https://plus.google.com/103455765046958159203" rel="publisher" />
<script type="text/javascript" async defer
  src="https://apis.google.com/js/platform.js?publisherid=103455765046958159203">
</script>



</head>
<body>











[fiatalert]


<style>
.fb-like {display: none;}
</style>
<style>
.fb-share-button {display: none;}
</style>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

            <div class="fixed">
<div id="top" class="top_bar">
    <div class="inner">
     			     <ul id="menu-top" class="top_nav"><li id="menu-item-16365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16365"><a href="#footer">Business Directory</a></li>
<li id="menu-item-16366" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16366"><a href="http://www.trussvilletribune.com/contact-us/">Contact Us</a></li>
<li id="menu-item-30913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30913"><a href="http://www.trussvilletribune.com/jobs/">Careers</a></li>
</ul>			       <div id="mobile_top_menu_secondary" class="menu-top-container"><select class="mobileTopMenu" id="mobileTopMenu" name="mobileTopMenu" onchange="location.href = document.getElementById('mobileMainMenu').value;"><option value="#footer" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16365">Business Directory</option><option value="http://www.trussvilletribune.com/contact-us/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16366">Contact Us</option><option value="http://www.trussvilletribune.com/jobs/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30913">Careers</option></select></div>    
   
    <div class="search_box">
        <form method="get" action="http://www.trussvilletribune.com">
<input type="submit" class="sb" value="Search" />
<input type="text" class="sf" value="Search here ..." name="s" onfocus="if(this.value == 'Search here ...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search here ...';}" />
</form>    </div> <!--Search Box-->
    </div> <!--End Inner-->
</div> <!--End Topbar-->

<header id="header">
    <div class="top_line"></div>
<div class="inner">
    <div class="logo">
<a href="http://www.trussvilletribune.com">
		<img src="http://www.trussvilletribune.com/wp-content/uploads/2012/06/tibanner1.gif" alt="The Trussville Tribune" />
	</a>
    </div> <!--End Logo-->
            <div class="top_ad">
                       <a href="http://complete-cleaners.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2012/06/webbannerAUG1-300x46.jpg" alt=""></a>
                </div> <!--End Top Ad-->
    </div> <!--Inner-->
</header> <!--End Header-->
<nav id="navigation">
    <div class="nav_wrap">
    <div class="inner">
     			     <ul id="menu-primary" class="nav"><li id="menu-item-5" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5"><a href="http://www.trussvilletribune.com/">Home</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-80"><a href="http://www.trussvilletribune.com/category/trussvilleclayandpinsonnews/">Local News</a>
<ul class="sub-menu">
	<li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="http://www.trussvilletribune.com/category/trussvilleclayandpinsonbusiness/">Business</a></li>
	<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="http://www.trussvilletribune.com/category/trussvilleclayandpinsonlifestyle/">Lifestyle</a></li>
	<li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84"><a href="http://www.trussvilletribune.com/category/opinions/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-81"><a href="http://www.trussvilletribune.com/category/trussvilleclayandpinsonsports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-15879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879"><a href="http://www.trussvilletribune.com/category/highschoolfootball/">High School Football</a></li>
	<li id="menu-item-15583" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15583"><a href="http://www.trussvilletribune.com/trib-tv/">Trib TV</a></li>
	<li id="menu-item-15890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15890"><a href="http://www.youtube.com/TribuneSportsLive">Video</a></li>
</ul>
</li>
<li id="menu-item-16368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16368"><a href="http://www.trussvilletribune.com/trib-tv/">Trib TV</a></li>
<li id="menu-item-4107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4107"><a href="http://www.trussvilletribune.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-7665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7665"><a href="http://www.trussvilletribune.com/this-weeks-paper/">E-Paper</a></li>
<li id="menu-item-29430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29430"><a href="http://www.trussvilletribune.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-29431" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29431"><a href="http://www.trussvilletribune.com/locallegal/">Local Legal</a></li>
	<li id="menu-item-29489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29489"><a href="http://www.trussvilletribune.com/political/">Political</a></li>
	<li id="menu-item-36241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36241"><a href="http://www.trussvilletribune.com/category/tribunetreasures/">Tribune Treasures</a></li>
</ul>
</li>
</ul>			      <div id="mobile_menu_secondary" class="menu-primary-container"><select class="mobileMainMenu" id="mobileMainMenu" name="mobileMainMenu" onchange="location.href = document.getElementById('mobileMainMenu').value;"><option value="http://www.trussvilletribune.com/" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5">Home</option><option value="http://www.trussvilletribune.com/category/trussvilleclayandpinsonnews/" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-80">Local News</option><option value="http://www.trussvilletribune.com/category/trussvilleclayandpinsonbusiness/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82">&nbsp;&nbsp;&nbsp;&nbsp;Business</option><option value="http://www.trussvilletribune.com/category/trussvilleclayandpinsonlifestyle/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83">&nbsp;&nbsp;&nbsp;&nbsp;Lifestyle</option><option value="http://www.trussvilletribune.com/category/opinions/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84">&nbsp;&nbsp;&nbsp;&nbsp;Opinion</option><option value="http://www.trussvilletribune.com/category/trussvilleclayandpinsonsports/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-81">Sports</option><option value="http://www.trussvilletribune.com/category/highschoolfootball/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15879">&nbsp;&nbsp;&nbsp;&nbsp;High School Football</option><option value="http://www.trussvilletribune.com/trib-tv/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15583">&nbsp;&nbsp;&nbsp;&nbsp;Trib TV</option><option value="http://www.youtube.com/TribuneSportsLive" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15890">&nbsp;&nbsp;&nbsp;&nbsp;Video</option><option value="http://www.trussvilletribune.com/trib-tv/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16368">Trib TV</option><option value="http://www.trussvilletribune.com/category/obituaries/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4107">Obituaries</option><option value="http://www.trussvilletribune.com/this-weeks-paper/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7665">E-Paper</option><option value="http://www.trussvilletribune.com/category/features/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29430">Features</option><option value="http://www.trussvilletribune.com/locallegal/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29431">&nbsp;&nbsp;&nbsp;&nbsp;Local Legal</option><option value="http://www.trussvilletribune.com/political/" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29489">&nbsp;&nbsp;&nbsp;&nbsp;Political</option><option value="http://www.trussvilletribune.com/category/tribunetreasures/" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36241">&nbsp;&nbsp;&nbsp;&nbsp;Tribune Treasures</option></select></div>    
   </div> <!--Inner-->
    </div> <!--End Nav Wrap-->
</nav> <!--End Navigation-->




<!-- <div class="headerbanner"><center><a href="http://www.trussvilletribune.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/12/cmasBanner16.jpg" width="800" height="99" /></a></center></div> -->

<!-- <div class="headerbanner"><center><a href="http://www.trussvilletribune.com/2017/01/05/friday-8-a-m-update-winter-storm-warning-issued-for-jefferson-st-clair-counties/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2017/01/winter-storm-watch1.jpg" width="800" height="99" /></a></center></div> -->

<!-- <div class="headerbanner"><center><a href="http://www.eventbrite.com/o/faith-community-fellowship-11748702231/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/11/L2L-TRIBUNE.jpg" width="800" height="99" /></a></center></div> -->



 


<!-- <center><iframe width="560" height="315" src="https://www.youtube.com/embed/RaksVPooKrY" frameborder="0" allowfullscreen></iframe></center> -->
<!-- <center><iframe width="560" height="315" src="https://www.youtube.com/embed/E5KE2dWKDuc" frameborder="0" allowfullscreen></iframe></center> -->
<!-- <center><iframe width="560" height="315" src="https://www.youtube.com/embed/BqT2Fcdyv_c?feature=player_detailpage&VQ=HD720" frameborder="0" allowfullscreen></iframe></center> -->
<!-- <center><iframe width="560" height="315" src="https://www.youtube.com/embed/o25jIdnH8CE?feature=player_detailpage&VQ=HD720" frameborder="0" allowfullscreen></iframe></center> -->
<!-- <center> <iframe src="https://www.youtube.com/embed/videoseries?list=PL0u1lZQN8DrKPaM2Z8UBCcD32Kw119IiQ" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></center> --><div class="inner">
    <div class="container">










    <div class="main">
	<div id="crumbs">You Are Here: <a href="http://www.trussvilletribune.com">Home</a> <span class='delimiter'>&raquo;</span> <a href="http://www.trussvilletribune.com/category/trussvilleclayandpinsonnews/">Local News</a> <span class='delimiter'>&raquo;</span> <span class="current">City plans, Polly Reed improvements, public safety highlights of Center Point City Council meeting</span></div>	<div class="box_outer">
    <article class="cat_article">
    <h1 class="cat_article_title">City plans, Polly Reed improvements, public safety highlights of Center Point City Council meeting</h1>
 	    <div class="article_meta">
 	       <span class="meta_author">Posted by: <a href="http://www.trussvilletribune.com/author/cyow/" title="Posts by Chris Yow" rel="author">Chris Yow</a></span>
		       <span class="meta_date">Posted date:  <strong>March 10, 2017</strong></span>
       
		    </div> <!--article meta-->
	    <div id="article_content" class="single_article_content">
       				        <div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="above-post" data-href="http://www.trussvilletribune.com/2017/03/10/city-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting/" data-share="true" data-show-faces="true" data-width="600"></div>
<p>By Nathan Prewett</p>
<p>For the Tribune</p>
<p>CENTER POINT – The Center Point City Council met early on Thursday night to hear a presentation on the first draft of long term plans for upgrades and improvements to the city. The plans range from marketing the city to potential buyers of property to improvements for infrastructure such as streetlights and transportation.</p>
<div id="attachment_34401" style="width: 310px" class="wp-caption alignleft"><a href="http://www.trussvilletribune.com/wp-content/uploads/2016/09/IMG_3030.jpg"><img class="size-medium wp-image-34401" src="http://www.trussvilletribune.com/wp-content/uploads/2016/09/IMG_3030-300x225.jpg" alt="" width="300" height="225" srcset="http://www.trussvilletribune.com/wp-content/uploads/2016/09/IMG_3030-300x225.jpg 300w, http://www.trussvilletribune.com/wp-content/uploads/2016/09/IMG_3030-1024x768.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p class="wp-caption-text">photo by Bethany Adams</p>
</div>
<p>Lindsay Puckett, a project manager from the Regional Planning Commission of Greater Birmingham, outlined the recommendations, suggesting “refreshing” community activities, as well as marketing and branding.</p>
<p>Other recommendations included addressing the issue of street lights in need of repairs and building a library in the city. She also said that the plans suggest building new sidewalks and implementing measures for speeding.</p>
<p>The next steps in the long-term plans will be to present them to the Planning and Zoning Commission for endorsement after they are reviewed by Mayor Henderson and then present the final drafts in a public meeting.</p>
<p>The Center Point City Council agreed on April 27 to vote on the plans.</p>
<p>Pre-Council followed the presentation, with the regular meeting at 7 p.m.</p>
<p>During public comments, resident Billy Hagood asked the council about the amount of traffic money that has been collected. Councilman Roger Barlow said that the collection amounts to approximately $97,000. Hagood then suggested that the council use the money for repairing a light in the parking lot along with other lights nearby.</p>
<p>The council heard from several speakers during the meeting, including a representative from CXT Concrete Buildings about using precast concrete from the company for future building projects.</p>
<p>Afterwards the council heard from Keith Strickland of Goodwyn, Mills and Caewood, who gave an update on work being done on Polly Reed Rd in Center Point. The project was first started in 2009 and is ongoing in improving the lanes on the road.</p>
<p>Strickland said that a focus of the project is road safety on Polly Reed, particularly with wide ditches on the sides of the road. The project will install a “very large” culvert drain system in the ditches to be later capped and covered before installing a pedestrian facility as an eight-foot-wide sidewalk on top.</p>
<p>The project will also resurface the road as well as implement utility relocation, including a Jefferson County sewer line that runs underneath the south portion of Polly Reed, several Alabama Power poles, a Trussville gas line and Birmingham Water facilities.</p>
<p>The project is being funded by an 80/20 grant in which 80 percent of the costs from construction will be paid by the Federal Government while 20 percent is paid by the city. It has recently secured environmental clearance for right of way acquisition. Following will be the relocation of the utilities. He said that the project will be ready for bid by the end of the year.</p>
<p>Strickland requested a supplement to the project. This was the second requested since 2014 which was granted then. Strickland said that this will be last one to be requested. The council voted unanimously to approve the supplement.</p>
<p>Public Safety Department Director Antonio Weatherly gave a report to the council on incidents reported to the department. Weatherly stressed the problem of drivers not coming to a full stop at stop signs throughout the city, as well as cars blocking pedestrian crossing markings while stopped.</p>
<p>Mayor Henderson announced that the papers for a grant for a storm shelter behind the Center Point Fire Station has gone through and will probably be finalized in September. He said that the Fire Department has mentioned adding an extra module to the shelter that will allow department members to operate in case the station is damaged.</p>
<p>The mayor said that he and Weatherly met with several apartment managers on Polly Reed RD to talk about cooperating with the city in cases of crimes being committed in their complexes. Mayor Henderson said that he will meet with other managers to discuss the same issue.</p>
<p>The next city council meeting will be held on March 23 with pre-council at 6:45 p.m. and regular meeting at 7 p.m.</p>
<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="below-post" data-href="http://www.trussvilletribune.com/2017/03/10/city-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting/" data-share="true" data-show-faces="true" data-width="600"></div>
	<div class="clear"></div>
    </div> <!--Single Article content-->
        <div class="dots"></div>
     	    <div class="articles_nav">
        <span class="prev_article"><a href="http://www.trussvilletribune.com/2017/03/09/pinson-woman-wanted-for-fta-on-possession-charges/" rel="prev"><span>&#8249;</span> Previous</a></span>
        <span class="next_article"> </span>
    </div> <!--Articles Nav-->
         	    
            
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="http://www.trussvilletribune.com/2017/03/10/city-plans-polly-reed-improvements-public-safety-highlights-of-center-point-city-council-meeting/" data-width="600" data-num-posts="15" data-order-by="reverse_time"></div>
</div></div>

    
	        <h4 class="related_box_title">Related posts</h4>
    <div class="related_box">
	<ul class="default">
    	                       <li class="related_item">
	<div class="related_image">
	        	    <a href="http://www.trussvilletribune.com/2017/03/09/pinson-woman-wanted-for-fta-on-possession-charges/">
                <img src="http://www.trussvilletribune.com/wp-content/themes/goodnews/framework/scripts/timthumb.php?src=http://www.trussvilletribune.com/wp-content/uploads/2017/03/stinson.png&amp;h=91&amp;w=126&amp;zc=1" alt="Pinson woman wanted for FTA on possession charges" title="Pinson woman wanted for FTA on possession charges" />
	    </a>
			</div> <!--Related Image-->
	
             <h3><a href="http://www.trussvilletribune.com/2017/03/09/pinson-woman-wanted-for-fta-on-possession-charges/">Pinson woman wanted for FTA on possession charges</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
	<div class="related_image">
	        	    <a href="http://www.trussvilletribune.com/2017/03/09/water-outage-at-service-rd-and-deerfoot-pkwy-in-trussville/">
                <img src="http://www.trussvilletribune.com/wp-content/themes/goodnews/framework/scripts/timthumb.php?src=http://www.trussvilletribune.com/wp-content/uploads/2017/03/bwwb.jpg&amp;h=91&amp;w=126&amp;zc=1" alt="Water outage at Service Rd. and Deerfoot Pkwy. in Trussville" title="Water outage at Service Rd. and Deerfoot Pkwy. in Trussville" />
	    </a>
			</div> <!--Related Image-->
	
             <h3><a href="http://www.trussvilletribune.com/2017/03/09/water-outage-at-service-rd-and-deerfoot-pkwy-in-trussville/">Water outage at Service Rd. and Deerfoot Pkwy. in Trussville</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
	<div class="related_image">
	        	    <a href="http://www.trussvilletribune.com/2017/03/09/school-tax-vote-costs-county-500k-voter-turnout-extremely-low/">
                <img src="http://www.trussvilletribune.com/wp-content/themes/goodnews/framework/scripts/timthumb.php?src=http://www.trussvilletribune.com/wp-content/uploads/2014/02/IMG_8971-e1393353254826.jpg&amp;h=91&amp;w=126&amp;zc=1" alt="School tax vote costs county $500k; voter turnout extremely low" title="School tax vote costs county $500k; voter turnout extremely low" />
	    </a>
			</div> <!--Related Image-->
	
             <h3><a href="http://www.trussvilletribune.com/2017/03/09/school-tax-vote-costs-county-500k-voter-turnout-extremely-low/">School tax vote costs county $500k; voter turnout extremely low</a></h3>

    </li>
     <!--End Related Style-->
                    <li class="related_item">
	<div class="related_image">
	        	    <a href="http://www.trussvilletribune.com/2017/03/08/springville-police-looking-for-suspects-in-theft/">
                <img src="http://www.trussvilletribune.com/wp-content/themes/goodnews/framework/scripts/timthumb.php?src=http://www.trussvilletribune.com/wp-content/uploads/2017/03/springville-pd.jpg&amp;h=91&amp;w=126&amp;zc=1" alt="Springville police looking for suspects in theft" title="Springville police looking for suspects in theft" />
	    </a>
			</div> <!--Related Image-->
	
             <h3><a href="http://www.trussvilletribune.com/2017/03/08/springville-police-looking-for-suspects-in-theft/">Springville police looking for suspects in theft</a></h3>

    </li>
     <!--End Related Style-->
                                                 
	         	    	</ul>
    </div> <!--Related Box-->
     <!--Related Enable-->










        </article> <!--End Single Article-->
	</div><!--Box outer-->
        </div> <!--End Main-->
        <aside class="sidebar">
	 	                 <div class="box_outer"><div class="widget"><form method="get" action="http://www.trussvilletribune.com">
<input type="submit" class="sb" value="Search" />
<input type="text" class="sf" value="Search here ..." name="s" onfocus="if(this.value == 'Search here ...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search here ...';}" />
</form></div></div><div class="box_outer"><div class="widget"><h3 class="widget_title">Tribune Sports Live</h3><div class="wid_border"></div>			<div class="textwidget"><iframe width="280" height="158" src="https://www.youtube.com/embed/videoseries?list=PL0u1lZQN8DrKPaM2Z8UBCcD32Kw119IiQ" frameborder="0" allowfullscreen></iframe></div>
		</div></div><div class="box_outer"><div class="widget"><h3 class="widget_title">Tribune Digital Media</h3><div class="wid_border"></div>			<div class="textwidget"><!-- <iframe width="280" height="158" src="//www.youtube.com/embed/videoseries?list=PLs4RO9Ou3chIp0z2Wl2wtZJnXRa58BXnV" frameborder="0" allowfullscreen></iframe> -->

<iframe width="280" height="158" src="https://www.youtube.com/embed/videoseries?list=PL0u1lZQN8DrI2tmOibx79wk74kgPDY6Z_" frameborder="0" allowfullscreen></iframe></div>
		</div></div><div class="box_outer"><div class="widget">		   	    <div class="custom_textwidget">
				<script type="text/javascript"><!--
/*
 Copyright 2016 The PCman Website Rotating Banner Code
 https://www.thepcmanwebsite.com
 This code is free to use provided this notice is not removed.
 Create your own custom banner code with banners
*/
mybanners=
[
"<a href=\"http://www.courtesybirmingham.com\"><img src=\"http://www.trussvilletribune.com/wp-content/uploads/2016/07/Courtesy300x250_Sales6.29_1036-e1470711021813.jpg\" width=\"\" height=\"\" alt=\"\" title=\"\" border=\"0\"></a>",
"<a href=\"http://www.facebook.com/mycrazyhorse\"><img src=\"http://www.trussvilletribune.com/wp-content/uploads/2016/12/unnamed.jpg\" width=\"\" height=\"\" alt=\"\" title=\"\" border=\"0\"></a>",
"<a href=\"http://www.trin.com\"><img src=\"http://www.trussvilletribune.com/wp-content/uploads/2015/01/trinTACC-e1421182963916.jpg\" width=\"\" height=\"\" alt=\"\" title=\"\" border=\"0\"></a>"
]
randomNumber = Math.random()
var show_mybanners = mybanners[Math.floor(randomNumber * mybanners.length)]
document.write(show_mybanners);
// --></script>
<noscript>
<a href="http://www.trin.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2015/01/trinTACC-e1421182963916.jpg" width="" height="" alt="" title="" border="0"></a>
</noscript>
			  </div>

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.vrbo.com/458881"><img src="http://www.trussvilletribune.com/wp-content/uploads/2017/01/Romar-Beach.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="custom_textwidget">
				<script type="text/javascript"><!--
/*
 Copyright 2016 The PCman Website Rotating Banner Code
 https://www.thepcmanwebsite.com
 This code is free to use provided this notice is not removed.
 Create your own custom banner code with banners
*/
mybanners=
[
"<a href=\"http://trimmdb.com\"><img src=\"http://www.trussvilletribune.com/wp-content/uploads/2016/06/TrimmUpdated-1.png\" width=\"\" height=\"\" alt=\"\" title=\"\" border=\"0\"></a>",
"<a href=\"http://jmgardens.com\"><img src=\"http://www.trussvilletribune.com/wp-content/uploads/2016/06/JMGwebside.jpg\" width=\"\" height=\"\" alt=\"\" title=\"\" border=\"0\"></a>"
]
randomNumber = Math.random()
var show_mybanners = mybanners[Math.floor(randomNumber * mybanners.length)]
document.write(show_mybanners);
// --></script>
<noscript>
<a href="http://jmgardens.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/JMGwebside.jpg" width="" height="" alt="" title="" border="0"></a>
</noscript>			  </div>

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.lightingconceptsal.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/09/lightingconceptsweb1.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.trussville.com/landing-rebates/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/10/TGW-Desktop-Square.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.bryantbank.com/houndstooth-card.php"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/Houndstooth-300x2501.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.trussvilletribune.com/locallegal/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/LocalLegal_250x250_PromoV2-e1462944349204.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.vrbo.com/37311"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/12/Romar-Ad-2016-A.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.alabamaorthopaedicsurgeons.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/ASOweb1.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div><div class="box_outer"><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.ewmotiontherapy.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/EWadWEBnew11.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div></div>	            </aside> <!--End Sidebar-->
            </div> <!--End Container-->
      <div class="bot_ad">
                       <a href="http://www.bryantbank.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2012/06/bryantbank.jpg" alt=""></a>
                </div> <!--End bot Ad-->
    </div> <!--End Inner-->
<footer id="footer">
<h3 id="footber"> </h3>
    <div class="footer_wrap">
        <div class="foot_border"></div>
    <div class="inner">
 	     			<div class="one_third">
		<div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.facebook.com/APlusTireAndAutoRepair/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/Aplus.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.controlledenvironmentinc.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/08/ECaug16web.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.facebook.com/TrussvilleVisionCare/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/TrussvilleVisionCareAd.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.barnettfurniture.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/BarnettFurniture.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://southernskiesdermatology.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/soskiesWEB1.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div>
			</div><!-- End third col -->
			<div class="one_third">
		<div class="widget">		   	    <div class="ads250">
			  			   <a href="http://www.parcelstoo.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2017/02/Parcels-Too-2017-048-30-1-LOC-279978-E-188-V1.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.facebook.com/FoxsPizzaAL/?fref=ts"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/FOX-ONLINE.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads250">
			  			   <a href="#"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/11/Roses-Web-Ad.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.bestace.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/Ace-Hardware-Website-Ad.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="https://www.facebook.com/Carroll-Pharmacy-in-Trussville-140880929279487/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/Screen-Shot-2016-04-11-at-8.43.04-AM.png" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div>			</div><!-- End third col -->
			<div class="one_third last">
		<div class="widget">		   	    <div class="ads300">
			  			   <a href="http://pigglywigglybirmingham.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/pigwigWeb.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://human.firstcommunitymortgage.com/staff-members/donna-lowery/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/10/Donna-Lowery.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.keystonefingrp.com/"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/06/Keystone-Financial-web1.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div><div class="widget">		   	    <div class="ads300">
			  			   <a href="http://www.lightingconceptsal.com"><img src="http://www.trussvilletribune.com/wp-content/uploads/2016/09/lightingconceptswebgray.jpg" alt="" /></a>
			  			  </div><!-- ads250 -->

			
</div>
			</div><!-- End third col -->
	        </div> <!--End Inner-->
    </div> <!--footer wrap-->
</footer> <!--End Footer-->
<div class="bottom_bar">
    <div class="inner">
    <ul class="social_icons">
                    <li class="twitter"><a href="#">twitter</a></li>
        
                <li class="facebook"><a href="#">facebook</a></li>        
        
                   <li class="gplus"><a href="#" >google plus</a></li>     
        
                        <li class="linkedin"><a href="#">LinkedIn</a></li>
        
                             <li class="rss"><a href="http://www.trussvilletribune.com/feed/">rss</a></li>
        
        
        
        

        
        
        
        
    </ul>
<p class="copyrights">Created by FerretNet - (http://www.ferretnet.com), AdLab and Filmdog Media (http://www.filmdogmedia.com).  Content & Website Copyright 2012 by the Trussville Tribune.</p>
    </div> <!--End Inner-->
</div> <!--end bottom Bar-->
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-content/themes/goodnews/js/custom.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"565982923603757"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='http://www.trussvilletribune.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<div id="fb-root"></div></div> <!--End Fixed-->
<div class="scrollTo_top">
    <a title="Scroll to top" href="#">
    	    <img src="http://www.trussvilletribune.com/wp-content/themes/goodnews/images/up.png" alt="Scroll to top">
        </a>
</div>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-33237376-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script></body>
</html>
